Archive

Archive for April, 2012

Runaway WMIPRVSE.EXE Process

April 27, 2012 Leave a comment

Environment

W2K3 machine
MOSS 2007 WFE

Symptoms

SharePoint was running slower than normal. Logged onto the WFE, opened Taskmgr.exe and found that the CPU was pegged. The culprit was the WMIPRVSE process.

Fix

After some investigation and restarting services, these are the steps that worked:

  • Kill the runaway process WMIPRVSE.EXE
  • Open Services.msc
  • Restart ScriptLogic CBM Service
  • Restart Window Management Instrumentation (which also restarted Citrx tools for Virtual Machines Service)

Because this server is due for retirement (after migration to SharePoint 2010), no further investigation of why the problem occurred was warranted.

Advertisements
Categories: SharePoint 2007

SharePoint 2007 AD Migration – Test

April 26, 2012 Leave a comment

Project – Test migrate SharePoint 2007 (MOSS) to a new Active Directory domain

  • Test farm has two servers – WFE and Database.
  • Quest Active Directory Migration Manager used to move server to new domain.
  • System accounts created in new domain with same rights on server as old domain accounts (Quest tool).
  • SQL Server Users created with accounts in the new domain with same database rights as the old domain accounts (Quest tool).

Problem

NEWDOMAIN\svc_admin_sp2 – can access Shared Service Provider (SSP) pages, but not Operations or Application Management in Central Admin.


Correction

Logged in to WFE with ID that could access Operations pages in Central Admin (OLDDOMAIN\svc_admin_sp2)

Run STSADM command to update the farm credentials –

Updates the Web application pool for the SharePoint Central Administration Web site and the Windows SharePoint Services Timer service (SPTimer).

http://technet.microsoft.com/en-us/library/cc262150(office.12).aspx>

stsadm -o updatefarmcredentials -identitytype configurableid -userlogin NEWDOMAIN\svc_admin_sp2 -password

Problem

Crawl not working.

Correction

Default content access account = OLDDOMAIN\svc_admin_sp2

Changed content access account to NEWDOMAINk\svc_admin_sp2 using Search Admin page

Started full crawl

Access OK – no errors in crawl log

Also ran these – which did not fix the problem but where run first and might be needed

Ran STSADM command migrate user for both accounts – had to be logged in as OLDDOMAIN\svc_setup_sp2 – with NEWDOMAIN\svc_setup_sp2 account got an Access Denied error.
Logged in as OLDDOMAIN\svc_setup_sp2 on SRV3 (DB server) – added NEWDOMAIN\svc_admin_sp2 to Farm Admin group (was missing).
Changed application pool accounts – logged in as OLDDOMAIN\svc_setup_sp2


Performed for LINC (the name of the main Web Application) and SSP
Checked Database rights with Magenium SharePoint Farm – all OK. However, the name of the Schema objects is not changed. For example – the NEWDOMAIN\svc_admin_sp2 login owns the OLDDOMAIN\svc_admin_sp2. I don’t think this is a problem.